On Call Engineers are Investigating

Incident Report for Twilio

Resolved

We have fully investigated the dead air calls and increased 404s issue, and it was determined that the impact was limited to a small set of customers, who have been contacted individually to address any concerns. All systems are operational.
Posted Apr 01, 2025 - 09:36 PDT

Investigating

We've become aware of a potential issue with customers reporting dead air calls and increased 404s. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Apr 01, 2025 - 09:34 PDT