We are no longer experiencing SMS delivery report delays to multiple networks in the United States of America via a subset of Short codes and Long codes.. The incident has been resolved.
Posted Mar 26, 2025 - 06:35 PDT
Monitoring
We are observing recovery in SMS delivery report delays to multiple networks in United States of America via a subset of Short codes and Long codes. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Mar 26, 2025 - 05:12 PDT
Investigating
We are experiencing SMS delivery report delays to multiple networks in United States of America via a subset of Short codes and Long codes. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Mar 26, 2025 - 04:52 PDT
This incident affected: CARRIER NETWORK (SMS Long Code, North America, SMS Short Code, North America).