Increased Latency in Creating Transcripts

Incident Report for Twilio

Resolved

Our engineers have monitored the fix and confirmed that the issue causing increased latency in creating transcripts has been resolved. All services are now operating normally at this time.
Posted Jul 03, 2025 - 09:30 PDT

Monitoring

Our engineers have implemented a fix and are monitoring system performance for the issue causing increased latency in creating transcripts We will provide another update in 2 hours or as soon as more information becomes available.
Posted Jul 03, 2025 - 07:35 PDT

Identified

Our engineers have identified an issue causing increased latency in creating transcripts due to a spike in received recordings and are working to deploy a fix. We expect to provide another update in 1 hour or as soon as more information becomes available.
Posted Jul 03, 2025 - 06:40 PDT
This incident affected: PROGRAMMABLE VOICE (Recording Transcriptions).