Dual Channel Conference Recordings Stuck In Progress

Incident Report for Twilio

Resolved

Twilio dual channel conference recording was degraded for 3 minutes between 9:59 AM and 10:02 AM Pacific Time on 07/10/2026. Dual channel conference recordings received during this time may be stuck 'in progress'. The issue has now been resolved.
Posted Jul 10, 2026 - 15:11 PDT

Investigating

Our monitoring systems have detected a potential issue with dual channel conference recordings. Our engineers have been alerted and are investigating. We will provide an update when we have more details.
Posted Jul 10, 2026 - 14:24 PDT
This incident affected: PROGRAMMABLE VOICE US1 (Conference US1).