SendGrid product switcher signup unavailable

Incident Report for Twilio

Resolved

We have deployed a fix to resolve the issue affecting customer signups when switching to SendGrid from Twilio. All signup flows have been verified and are functioning as expected. If you continue to experience issues, please contact support.
Posted Aug 13, 2026 - 14:02 PDT

Identified

We have identified the root cause of the issue affecting the signup page for customers attempting to switch to SendGrid from Twilio. Our engineering team is currently working on applying a fix. We will provide another update as soon as more information becomes available.
Posted Aug 13, 2026 - 13:32 PDT

Update

We are aware of an issue affecting the signup page for customers attempting to switch to SendGrid from Twilio. Customers may experience inability to complete the product switcher signup flow. Our team is actively investigating. We will provide another update as soon as more information becomes available.
Posted Aug 13, 2026 - 12:41 PDT

Investigating

We are aware of an issue affecting the signup page for customers attempting to switch to SendGrid from Twilio. Customers may experience inability to complete the product switcher signup flow. Our team is actively investigating. We will provide another update as soon as more information becomes available.
Posted Aug 13, 2026 - 12:34 PDT
This incident affected: SendGrid Website.