The incident is resolved and block rates are back to normal but customers will see change in block classifications from Microsoft 365. Users that continue to see elevated blocks can submit delisting requests to Microsoft by sending an email with a copy of the error message, and the blocked IP address, to "delist@microsoft.com".
Delisting requests can also be made via the Office 365 Anti-Spam IP Delist Portal at https://sender.office.com/
Posted Aug 14, 2026 - 19:05 PDT
Update
We are seeing reduction in block rates and some customers are indicating improvements. We will continue to monitor for any further updates.
Posted Aug 14, 2026 - 18:53 PDT
Update
We are continuing to monitor for any further issues.
Posted Aug 14, 2026 - 18:37 PDT
Monitoring
Beginning Aug 14 2026, ~21:45 UTC, we have observed an increase of 10-15% in blocks from Microsoft 365 impacting all Twilio Sendgrid IPs. We have confirmed with other industry contacts that they are observing similar behavior. The blocks are being observed at many domains hosted by Microsoft 365 and are not confined to a specific subset of recipient domains.
The blocks are variation of the following: 550 5.7.511 Access denied, banned sender[x.x.x.x]. To request removal from this list please forward this message to delist@microsoft.com. For more information please go to http://go.microsoft.com/fwlink/?LinkId=526653. AS(1410)
Delivery to Microsoft Outlook Consumer ("OLC"), for domains such as 'hotmail.com', 'outlook.com', etc., does not appear to be impacted. We will be monitoring and providing updates as new information becomes available.