SMS Delivery Delays from a Subset of Twilio Short Codes to ISP Telecom United States

Incident Report for Twilio

Resolved

We have fully investigated the SMS delivery delays from a subset of Twilio Short Codes to ISP Telecom network subscribers in the United States, and it was determined that the impact was limited to a small set of customers, who have been contacted individually to address any concerns. All systems are operational.
Posted Mar 17, 2026 - 16:41 PDT

Update

Twilio customers may be still experiencing SMS delivery delays from a subset of Twilio Short Codes to ISP Telecom network subscribers in the United States. Our team is actively investigating this issue. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Mar 17, 2026 - 15:10 PDT

Update

Twilio customers may be experiencing SMS delivery delays from a subset of Twilio Short Codes to ISP Telecom network subscribers in the United States. Our team is actively investigating this issue. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Mar 17, 2026 - 14:24 PDT

Update

Twilio customers may be experiencing SMS delivery delays from a subset of Twilio Short Codes to ISP Telecom network subscribers in the United States. Our team is actively investigating this issue. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Mar 17, 2026 - 14:22 PDT

Update

Twilio customers may be experiencing SMS delivery delays from a subset of Twilio Short Codes to ISP Telecom network subscribers in the United States. Our team is actively investigating this issue. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Mar 17, 2026 - 14:07 PDT

Investigating

Twilio customers may be experiencing SMS delivery delays from a subset of Twilio Short Codes to ISP Telecom network subscribers in the United States. Our team is actively investigating this issue. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Mar 17, 2026 - 13:55 PDT
This incident affected: PROGRAMMABLE MESSAGING (SMS).