SMS Delivery Failure to Multiple Networks in Mexico via a Subset of Twilio Numbers
Incident Report for Twilio
Resolved
We are no longer experiencing SMS delivery failures to multiple networks in Mexico via a subset of Twilio numbers. This incident has been resolved.
Posted Nov 17, 2024 - 04:58 PST
Monitoring
We are observing successful SMS delivery to multiple networks in Mexico via a subset of Twilio numbers. We will continue to monitor to ensure full service recovery. We expect to provide another update in 2 hours or as soon as more information becomes available.
Posted Nov 17, 2024 - 03:25 PST
Investigating
We are experiencing SMS delivery failure to multiple networks in Mexico via a subset of Twilio numbers. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 1 hour or as soon as more information becomes available.
Posted Nov 17, 2024 - 02:29 PST
This incident affected: CARRIER NETWORK (SMS, Latin America).