Customers are Unable to Submit a Ticket through Twilio Help Center

Incident Report for Twilio

Resolved

Twilio customers using the Twilio Help Center without a paid support plan were unable to contact support through ticket submission since approximately April 1, 2025 at 4:00 PM PST. Paid support and Personalized support customers were unaffected. This issue was resolved on April 1, 2025 at approximately 12:00 PM PST.
Posted Apr 02, 2025 - 12:25 PDT

Investigating

We've become aware of a potential issue with Submitting a ticket via the Console. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Apr 02, 2025 - 12:07 PDT