Flex Agents Experiencing Errors with Interaction Participants

Incident Report for Twilio

Resolved

We have fully investigated the Flex Agents delays or errors when fetching Interaction Participants, and it was determined that the impact was limited to a small set of customers, who have been contacted individually to address any concerns. All systems are operational.
Posted Mar 09, 2026 - 13:19 PDT

Investigating

Our monitoring systems have detected a potential issue with Flex agent page. Our engineers have been alerted and are investigating. We will provide an update when we have more details.
Posted Mar 09, 2026 - 12:08 PDT
This incident affected: FLEX (Flex Agent Desktop).