On Call Engineers are Investigating

Incident Report for Twilio

Resolved

We have fully investigated the RCS Delivery Failure issue, and it was determined that the impact was limited to a small set of customers, who have been contacted individually to address any concerns. All systems are operational.
Posted Mar 17, 2026 - 18:51 PDT

Investigating

Our monitoring systems have detected a potential issue with RCS Delivery Failure. Our engineers have been alerted and are investigating. We will provide an update when we have more details.
Posted Mar 17, 2026 - 18:23 PDT