SMS Delivery Failures To Telefonica Network In Mexico Via A Subset Of Longcodes

Incident Report for Twilio

Resolved

The incident has been resolved and SMS delivery from a subset of Twilio Long Codes to Telefonica network subscribers in Mexico is operating normally.
Posted Mar 10, 2026 - 04:12 PDT

Update

Twilio customers may continue to experience SMS delivery failures from a subset of Twilio Phone Numbers to Telefonica network subscribers in Mexico. Our team is actively working to resolve the issue. We will provide another update in 24 hours or as soon as more information becomes available.
Posted Mar 09, 2026 - 15:16 PDT

Update

Twilio customers may continue to experience SMS delivery failures from a subset of Twilio Phone Numbers to Telefonica network subscribers in Mexico. Our team is actively working to resolve the issue. We will provide another update in 24 hours or as soon as more information becomes available.
Posted Mar 08, 2026 - 15:16 PDT

Update

Twilio customers may continue to experience SMS delivery failures from a subset of Twilio Phone Numbers to Telefonica network subscribers in Mexico. Our team is actively working to resolve the issue. We will provide another update in 16 hours or as soon as more information becomes available.
Posted Mar 07, 2026 - 23:26 PST

Update

Twilio customers may continue to experience SMS delivery failures from a subset of Twilio Phone Numbers to Telefonica network subscribers in Mexico. Our team is actively working to resolve the issue. We will provide another update in 8 hours or as soon as more information becomes available.
Posted Mar 07, 2026 - 15:31 PST

Update

Twilio customers may continue to experience SMS delivery failures from a subset of Twilio Phone Numbers to Telefonica network subscribers in Mexico. Our team is actively working to resolve the issue. We will provide another update in 4 hours or as soon as more information becomes available.
Posted Mar 07, 2026 - 11:43 PST

Update

Twilio customers may continue to experience SMS delivery failures from a subset of Twilio Phone Numbers to Telefonica network subscribers in Mexico. Our team is actively working to resolve the issue. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Mar 07, 2026 - 09:46 PST

Identified

Twilio customers may be experiencing SMS delivery failures from a subset of Twilio Phone Numbers to Telefonica network subscribers in Mexico. Our team has identified the cause, and is working to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Mar 07, 2026 - 08:48 PST

Investigating

Twilio customers may be experiencing SMS delivery failures from a subset of Twilio Phone Numbers to Telefonica network subscribers in Mexico. Our team is actively investigating this issue. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Mar 07, 2026 - 07:50 PST
This incident affected: CARRIER NETWORK (SMS, Latin America).