Account Security US Verizon API Issue

Incident Report for Twilio

Resolved

The issues affecting Account Security - US Verizon API have been resolved and the service is operating normally at this time.
Posted Oct 15, 2025 - 12:43 PDT

Update

We have started seeing recovery for intermittent issue with Account Security - US Verizon API. We will continue to monitor to ensure a full recovery. We expect to provide another update in 2 hours or as soon as more information becomes available.
Posted Oct 15, 2025 - 10:44 PDT

Monitoring

We have started seeing recovery for intermittent issue with Account Security - US Verizon API. We will continue to monitor to ensure a full recovery. We expect to provide another update in 30 minutes or as soon as more information becomes available.
Posted Oct 15, 2025 - 10:13 PDT

Update

We continue investigating the issue with Account Security - US Verizon API. Our engineering team has been alerted and is actively working on a resolution. We expect to provide another update in 2 hours or as soon as more information becomes available.
Posted Oct 15, 2025 - 07:41 PDT

Update

Our monitoring systems have detected a potential issue with Account Security - US Verizon API. Our engineering team has been alerted and is actively investigating. We expect to provide another update in 1 hour or as soon as more information becomes available.
Posted Oct 15, 2025 - 06:38 PDT

Investigating

Our monitoring systems have detected a potential issue with Account Security. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Oct 15, 2025 - 06:31 PDT
This incident affected: CARRIER NETWORK (Lookup Identity Match).