Users cannot select plans in the account onboarding flow

Incident Report for Twilio

Resolved

Our engineers have monitored the fix and confirmed the issue with the onboarding plan-selection has been resolved. All services are now operating normally at this time.
Posted Jul 14, 2026 - 12:37 PDT

Monitoring

The issue has been identified and a fix has been implemented. We will keep monitoring for 30 minutes.
Posted Jul 14, 2026 - 12:00 PDT

Identified

The issue has been identified and a fix is being implemented. We will provide an update in 1 hour or as soon as more information becomes available.
Posted Jul 14, 2026 - 11:04 PDT

Update

In the Onboarding plan-selection screen clicking a card doesn't select the chosen card. The radio dot flashes and defaults to the default value. We will provide an update in 1 hour or as soon as more information becomes available.
Posted Jul 14, 2026 - 10:45 PDT

Investigating

Our monitoring systems have detected a potential issue with Upgrade. Our engineers have been alerted and are investigating. We will provide an update when we have more details.
Posted Jul 14, 2026 - 10:40 PDT
This incident affected: TWILIO PLATFORM (Other).