Phone Numbers Porting are failing in both Twilio Console and API

Incident Report for Twilio

Resolved

We are no longer experiencing phone numbers porting in both Twilio console and our API. This incident has been resolved.
Posted May 10, 2026 - 21:27 PDT

Monitoring

We are observing recovery in phone numbers porting in both Twilio console and API. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
Posted May 10, 2026 - 19:22 PDT

Investigating

Our monitoring systems have detected a potential issue with phone numbers porting in both Twilio console and API. Our engineers have been alerted and are investigating. We will provide an update when we have more details.
Posted May 10, 2026 - 19:06 PDT
This incident affected: PHONE NUMBERS.